I.S.I.L - Institut Supérieur des Ingénieurs Liégeois

Nous vous souhaitons la bienvenue et une bonne visite sur le forum de
I.S.I.L - Institut Supérieur des Ingénieurs Liégeois

Merci de vous connecter ou vous inscrire.
I.S.I.L - Institut Supérieur des Ingénieurs Liégeois

Forum d'entraide


    Tableur Calc

    Partagez

    Thibaut
    Disciple
    Disciple

    Messages : 78
    Date d'inscription : 14/02/2009

    Tableur Calc

    Message par Thibaut le Sam 10 Oct - 13:28

    Bonjour tout le monde,

    Voilà j'ai un petit problème avec le labo 1, pour la partie SI (5ème feuille), je n'arrive pas à trouver la syntaxe, pour avoir TTB, Tb... etc.

    J'ai compris le principe des SI mais je n'arrive pas à l'écrire...

    Je n'arrive pas non plus à interdire en écriture les cellules de la feuille 6, j'ai été dans format-cellules-protection, j'ai décoché "protéger", puis j'ai sélectionné les cellules turquoises pour les verrouiller, mais ça ne fonctionne pas...


    Merci.

    madison
    Apprenti
    Apprenti

    Messages : 20
    Date d'inscription : 12/02/2009

    Re: Tableur Calc

    Message par madison le Sam 10 Oct - 14:30

    =SI(E7>=18;"TTB"; SI(E7>=16;"tb"; SI(E7>=14;"B"; SI(E7>=12;"S"; SI(E7>=10;"Passable"; SI(E7<10;"Echec"))))))
    avatar
    PierreC
    Ingénieur
    Ingénieur

    Messages : 366
    Date d'inscription : 04/02/2009

    Re: Tableur Calc

    Message par PierreC le Sam 10 Oct - 14:41

    Il y a plusieures méthodes:
    Je vais en détailler deux.
    la première avec une suite de simples conditions:
    (la méthode la plus rudimentaire)
    Code:
    =SI(cote<10;"Échec";SI(cote<12;"passable";SI(cote<14;"S";SI(cote<16;"B";SI(cote<18;"Tb";SI(cote<=20;"TTB";" "))))))

    La deuxième se base sur les doubles conditions:

    Code:
    =SI(ET(cote<10; cote>=0);"Échec";SI(ET(cote<12; cote>=10);"Passable";SI(ET(cote<14;cote >=12); "S";SI(ET(cote<16; cote>=14 ); "B";SI(ET(cote<18; cote>=16); Tb;SI(ET(cote<=20; cote>=18);"TTB";SI(OU(cote<0; cote>20);"Erreur cote";" ")))))))
    Comparons maintenant ces deux méthodes, la première trie la cote entrée depuis - "l'infinie" à 20, elle est courte, mais imparfaite. (Mais néanmoins correcte si la case Cote est paramétrée pour n'accueillir que des cotes de 0 à 20)
    La seconde méthode elle est plus lourde, car chaque ensemble est considéré et pour finir la dernière condition élimine toutes les cotes invalides.

    Dans les deux cas la recette est de faire des conditions dans des conditions. (un peu exigeant n'est-ce pas ^^)




    Concernant la protection, sous office 2007 après avoir désactivé la protection dans les cellules visées il faut aller dans l'onglet révision puis cliquer sur "Protèger la feuille" on te demandera alors quelles protections t'intéresses précisément je te conseille de ne permettre la protection que des cellules déverrouillées.
    NB: Il n'est pas nécessaire de cliquer sur verrouiller, car par défaut toutes les cellules ont un statut "Verrouillé"
    NB': Dans le choix de protection il te sera aussi demandé un pass, tu peux soit en entrer un soit laisser vide pour ne pas mettre de mdp.

    Dans Openoffice, c'est la même chose sauf que pour protéger il faut aller dans le menu déroulant "Outil=>protéger document=>feuille ou document selon tes envies."


    Edit: Madison a été plus rapide, sa méthode est également correcte mais il faut alors s'assurer que l'utilisateur ne puisse entrer une cote hors de [0;20] autrement il y aura une erreure de conception.






    Thibaut
    Disciple
    Disciple

    Messages : 78
    Date d'inscription : 14/02/2009

    Re: Tableur Calc

    Message par Thibaut le Sam 10 Oct - 16:14

    OK,

    Merci beaucoup à tout les deux! Very Happy

    Bon week-end.

    Contenu sponsorisé

    Re: Tableur Calc

    Message par Contenu sponsorisé


      La date/heure actuelle est Dim 22 Oct - 0:56